Page 3 sur 3 PremièrePremière 1 2 3
Affichage des résultats 31 à 39 sur 39

Discussion: images d'un prefix au lieu du texte

  1. #31
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Non c'est à mettre avant ou après, ça n'a pas d'importance, en tout cas sur le style par défaut, si tu utilises un style personnalisé, et que celui ci soit modifié via le template additional.css, alors il faut le mettre à la fin, car c'est la dernière class de la me^me famille, qui prend le dessus.

    Donc ça donne ceci par exemple:

    Code:
    .breadcrumb .navbit.lastnavbit span .resolu, .resolu {
    background: transparent url({vb:stylevar imgdir_misc}/ok.png) no-repeat 0 50%; /* image de mon préfixe résolu ! avec son positionnement, ici centré verticalement, et totalement à gauche de la balise SPAN*/
    padding: 0 2px 0 127px; /* positionnement de mon préfixe et de ce qu'il l*entoure par rapport à mon image, ici 2px à droite pour espacé le titre, et 12px à gauche pour le positionnement de mon préfixe en texte par rapport à mon image */
    color: #9BC55A; /* couleur du texte de mon préfixe, dans ce cas en rapport à la couleur de mon image */
    display: inline-block; /* inline-block pour éviter tout saut de ligne du titre, peut-être remplacé par un float:left*/
    height: 30px; /* hauteur de l'image*/
    line-height: 30px; /* hauteur correspondant à celle de l'image, pour que le texte soit centré verticalement */
    } 
    
    .breadcrumb .navbit.lastnavbit span, .breadcrumb .navbithome, .breadcrumb .navbit a {
    line-height: 30px;
    }
    La première permet la mise en place du style sur les préfixes sur les pages forumhome, forumdisplay et showthread, la deuxième class "breadcrumb .navbit.lastnavbit span, .breadcrumb .navbithome, .breadcrumb .navbit a" permet l'alignement vertical du préfixe et du titre de sujet sans oublier les nom précédents des forum ou sous forum ou ce trouve ce sujet dans la navbits sur la page showthread.

  2. #32
    Date d'inscription
    août 2004
    Localisation
    vaucluse
    Âge
    55
    Messages
    283
    Version de vBulletin
    4.2
    Hébergeur
    maven
    Pouvoir de réputation
    67
    ok tout compris! mais peux tu confirmer qu'avec un style qui a un background noir les images n'apparaissent pas? merci

  3. #33
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    J'ai pas compris ta question, tu as un exemple?

  4. #34
    Date d'inscription
    août 2004
    Localisation
    vaucluse
    Âge
    55
    Messages
    283
    Version de vBulletin
    4.2
    Hébergeur
    maven
    Pouvoir de réputation
    67
    j'utilise en plus du theme par defaut avec lequel tout fonctionne bien le theme Seamus, et ce dernier mon image est semble t-il toujours présente mais recouverte de la couleur du theme, donc noir, une petite capture, on voit nettement la forme rectangulaire de mon image de préfixe
    Dernière modification par Eve_Ra ; 24/05/2013 à 22h34. Motif: Retrait de l'image hébergée par un site douteux

  5. #35
    Date d'inscription
    août 2004
    Localisation
    vaucluse
    Âge
    55
    Messages
    283
    Version de vBulletin
    4.2
    Hébergeur
    maven
    Pouvoir de réputation
    67
    pourquoi je suis modéré dans mes posts?

  6. #36
    Date d'inscription
    mars 2003
    Localisation
    Sur mon coussin
    Messages
    5 556
    Version de vBulletin
    4.2
    Hébergeur
    localhost
    Pouvoir de réputation
    100
    Parce que l'anti-spam du forum a détecté un site plus que douteux : quand on clique sur ton image, il y a au moins quatre fenêtres qui s'ouvrent.
    Mets ton image en pièce jointe depuis ton ordinateur, au moins on n'aura plus de problème.
    Dernière modification par Eve_Ra ; 24/05/2013 à 22h36.
    Miaouuu... ne me caressez pas à rebrousse-poils, ça fait de l'électricité !
    Aucune demande d'aide par mp ne sera prise en compte !

  7. #37
    Date d'inscription
    août 2004
    Localisation
    vaucluse
    Âge
    55
    Messages
    283
    Version de vBulletin
    4.2
    Hébergeur
    maven
    Pouvoir de réputation
    67
    marche pas pour moi les pièces jointes ici, tant pis

  8. #38
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Citation Envoyé par mitch84 Voir le message
    j'utilise en plus du theme par defaut avec lequel tout fonctionne bien le theme Seamus, et ce dernier mon image est semble t-il toujours présente mais recouverte de la couleur du theme, donc noir, une petite capture, on voit nettement la forme rectangulaire de mon image de préfixe
    Tu as un lien du préfixe en place sur le style dont tu parles, que je vois le comportement?

  9. #39
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Je re poste ma question, car mon message avec la citation de ta réponse, sans l'image qui occasionait la modération de ce dernier, est modéré aussi...

    Tu as un lien du préfixe en place sur le style dont tu parles, que je vois le comportement?

Informations de la discussion

Utilisateur(s) sur cette discussion

Il y a actuellement 1 utilisateur(s) naviguant sur cette discussion. (0 utilisateur(s) et 1 invité(s))

Les tags pour cette discussion

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •