Page 1 sur 3 1 2 3 DernièreDernière
Affichage des résultats 1 à 15 sur 40

Discussion: J'ai été piraté par AjayDisket

  1. #1
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    J'ai été piraté par AjayDisket

    Bonjour,

    Je ne peux faire ce qui est proposé ici et . Car lorsque je vais sur l'admincp de mon site http://www.extraitsdediscussions.com/forums/admincp, j'ai le message suivant : «Sorry Admin Your Website Has Been Hacked!! Please Patch It Or I Will Back».

    Que puis-je faire ?

    De plus, je viens de m'apercevoir que je n'ai même plus accès à mon site.

    Voici le message que j'obtiens par courriel lorsque je tente d'accéder à mon site :

    Database error in vBulletin :

    mysqli_real_connect() [<a href='function.mysqli-real-connect'>function.mysqli-real-connect</a>]: (HY000/2002): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    /home/extraits/public_html/forums/includes/class_core.php on line 1356

    MySQL Error :
    Error Number :
    Request Date : Sunday, October 27th 2013 @ 05:01:57 PM
    Error Date : Sunday, October 27th 2013 @ 05:01:57 PM
    Script : http://www.extraitsdediscussions.com...&sortby=recent
    Referrer :
    IP Address : J'ai remplacé le numéro de ip par ce texte
    Username :
    Classname : vB_Database_MySQLi
    MySQL Version :

    Shalom !
    Dernière modification par Semeur ; 27/10/2013 à 22h16.

  2. #2
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Bonsoir,

    Avant ce hack avais tu laissé ton dossier "install" sur ton ftp? C'est afin de savoir par ou il est passé pour modifier ton admincp.

    Tu dis ne plus avoir accès à ton amdincp, commence par remplacer les fichiers de ton vbulletin par la même version que ceux présent sur ton ftp, et essaye à nouveau, si la modification vise un fichier cela devrait te permettre de poursuivre un nettoyage de fichier, sinon c'est qu'il à toucher à ta dB aussi, il te faudra je pense opter pour uen restauration de dB en croisant les doigts que tu en ais une récente?

    Après il faudra que tu nous tienne au courant afin que l'on te guide en fonction de tes actions.

  3. #3
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    Je tente de comprendre ce que tu me dis de faire

    Citation Envoyé par jolinary Voir le message
    Avant ce hack avais tu laissé ton dossier "install" sur ton ftp?
    Pendant un certain temps il y était, mais renommé, sous «/public_html/forums» chez mon hébergeur. Je l'ai détruit et j'ai pu pendant un certain temps accéder à mon admincp. Quand tu parles de sous mon ftp est-ce de «/public_html» chez mon hébergeur que tu parles ?

    Citation Envoyé par jolinary Voir le message
    C'est afin de savoir par ou il est passé pour modifier ton admincp.
    J'ai trouvé le fichier «x.txt» sous «/public_html» chez mon hébergeur. Sa date de modification est le 13 sept 2013. Voici son contenu : «Hacked by SultanHaikal»

    Citation Envoyé par jolinary Voir le message
    commence par remplacer les fichiers de ton vbulletin par la même version que ceux présent sur ton ftp,
    Pour ce faire:
    0- Supprimer le répertoires «/public_html/forums» chez mon hébergeur
    1- Je recopie avec FileZilla le répertoire «forums» de ma version vb qui est sur mon pc vers «/public_html» chez mon hébergeur;
    2- Je détruis sous «/public_html/forums/install» chez mon hébergeur
    3- Je détruis «/public_html/x.txt» chez mon hébergeur
    4- Désactiver tous les plug-ins de mon navigateur Firefox
    5- Inscire ceci dans mon navigateur : //http://www.extraitsdediscussions.com/forums//install/upgrade.php
    6- Activer tous les plug-ins de mon navigateur Firefox

    J'attend ton commentaire avant de procéder.

    Citation Envoyé par jolinary Voir le message
    et essaye à nouveau, si la modification vise un fichier cela devrait te permettre de poursuivre un nettoyage de fichier, sinon c'est qu'il à toucher à ta dB aussi, il te faudra je pense opter pour une restauration de dB en croisant les doigts que tu en ais une récente?

    Après il faudra que tu nous tienne au courant afin que l'on te guide en fonction de tes actions.
    On verra.

    ===================== Ajout le 2013-10-28 =============

    Voici ce que j'ai au premier niveau sous mon répertoire «/public_html» chez mon hébergeur :

    Les répertoires suivant :
    cgi-bin
    forums (C'est mon forum)
    forums1 (C'est mon forum de test)

    Les fichiers suivant :
    .htaccess
    index.php
    x.txt

    Voici ce que j'ai au premier niveau sous mon répertoire racine chez mon hébergeur :

    Les répertoires suivant :
    .cagefs
    .cl.selector
    .cpanel
    .fontconfig
    .gem
    .htpasswds
    .softaculous
    .trash
    access-logs (ce répertoire a le logo du raccourci)
    bin
    cpmove.psql
    cpmove.psql.1362388743
    etc
    logs
    mail
    php
    public_ftp
    public_html
    ssl
    tmp
    www (ce répertoire a le logo du raccourci)

    Les fichiers suivant :
    .bash_history
    .bash_logout
    .bash_profile
    .bashrc
    .contactemail
    .gemrc
    .inodes
    .inodesdist
    .lastlogin
    .my.cnf
    .pearrc
    cpbackup-exclude.conf
    Dois-je faire le ménage dans ce répertoire racine de mon hébergeur ?

    N.B.: Sans rien faire, mon forum (pas le admincp) est de nouveau accessible.

    Shalom !
    Dernière modification par Semeur ; 28/10/2013 à 21h18.

  4. #4
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    J'attends vos commentaires avant de continuer

    Bonjour,

    Pourquoi je n'ai pas de réponse ?

    Je ne sais pas si c'est correcte de faire les 7 étapes que je propose dans mon message précédent. Je ne sais pas s'il manque une étape.

    Dans ces étapes, je n'ai pas parlé de certains répertoires spécifiques à moi que je copierais tout de suite après l'étape 01. Sur mon PC, j'ai conservé les répertoires maison HTM, PDF et un répertoire maison Images. Les 2 premiers répertoires seront copiés sous «/public_html/forums» chez mon hébergeur, tandis que le contenu du 3ème sera copié dans le répertoire «/public_html/forums/images» de mon hébergeur.

    Je ne sais pas si je dois faire comme une installation de vBulletin ou comme une mise à jour de Vbulletin tel qu'on le voit ici. Ou l'opération que je dois faire est tout autre.

    jolinary, dois-je espérer ou non que tu me répondes ?

    Shalom !
    Dernière modification par Semeur ; 30/10/2013 à 02h13.

  5. #5
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Bonjour,

    Je lirais ta réponse ce soir attentivement, afin d'essayer de te répondre.

    - - - Mise à jour - - -

    Inutile pour le moment de supprimé le dossier de ton installation de vbulletin, le but étant d'avoir accès dans un premier temps à ton admincp.

    Remplace tout les fichiers vbulletin par ceux de l'archive de ce dernier que tu auras préalablement téléchargé sur vb.com, attention, si tu as modifié un ou plusieurs fichiers tu perdras ces modifications.

    Une fois la totalité des fichiers vbuleltin remplacés, essaye d'accéder à ton admincp, inutile de lancé un upgrade pour le moment, le but étant de savoir ton impossibilité d'accès à ton admincp vient de l'un des fichiers vbulletin modifiés.

    Et dis nous ce que tu vois sur la page si cela ne marche toujours pas en remplacent les fichiers, bien entendu si un fichier sur ton espace d'hébergement n'a rien à faire là, tu le supprimes.

    Il faut y aller étape par étape.

  6. #6
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    On continue

    Mes questions peuvent te sembler pointilleuses ou enfantines mais j'aime mieux m'assurer que je te comprenne bien.
    Citation Envoyé par jolinary Voir le message
    Inutile pour le moment de supprimé le dossier de ton installation de vbulletin, le but étant d'avoir accès dans un premier temps à ton admincp.
    Ok.

    Citation Envoyé par jolinary Voir le message
    Remplace tout les fichiers vbulletin par ceux de l'archive de ce dernier que tu auras préalablement téléchargé sur vb.com,
    J'ai la même version sur mon PC de vbulletin que celle en force chez mon hébergeur soit 4_4-2-1.

    Est-ce que faire ce qui suit correspond à ce que tu me demandes de faire :

    1- Je recopie avec FileZilla le répertoire «forums» qui est sous le répertoire «vbforum_4_4-2-1_#personnel» sur mon PC vers «/public_html» chez mon hébergeur;
    2- Je détruis sous «/public_html/forums/install» chez mon hébergeur car sur mon PC ce répertoire existe.

    Citation Envoyé par jolinary Voir le message
    attention, si tu as modifié un ou plusieurs fichiers tu perdras ces modifications.
    Ok. Je n'ai pas modifié de fichier.

    Citation Envoyé par jolinary Voir le message
    Une fois la totalité des fichiers vbuleltin remplacés, essaye d'accéder à ton admincp, inutile de lancé un upgrade pour le moment, le but étant de savoir ton impossibilité d'accès à ton admincp vient de l'un des fichiers vbulletin modifiés.

    Et dis nous ce que tu vois sur la page si cela ne marche toujours pas en remplacent les fichiers, bien entendu si un fichier sur ton espace d'hébergement n'a rien à faire là, tu le supprimes.

    Il faut y aller étape par étape.
    Ma première étape est de m'assurer que je copie les bonnes choses au bon endroit.

    Shalom !

  7. #7
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Je recopie avec FileZilla le répertoire «forums» qui est sous le répertoire «vbforum_4_4-2-1_#personnel» sur mon PC vers «/public_html» chez mon hébergeur;
    Oui tu peux faire cela, si ces fichiers sont opérationnel, donc si ton forum en local fonctionne sans soucis.

  8. #8
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46
    Citation Envoyé par jolinary Voir le message
    Oui tu peux faire cela, si ces fichiers sont opérationnel, donc si ton forum en local fonctionne sans soucis.
    Je n'ai pas de forum d'actif en local sur mon PC. Ce que j'ai sur mon PC est le résultat de l'extraction du fichier vbforum_4_4-2-1_#personnel.zip qui provient de vb.
    C'est le répertoire «upload» renommé en «forums» que je compte copier vers mon hébergeur. Est-ce ok ? Sinon l'archive dont tu parles ce trouve à quel endroit ?

  9. #9
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Je vais être le plus clair possible, tu as téléchargé sur le site officiel vbulletin.com une archive en RAR, celle ci comme tu l'indique contient un dossier "UPLOAD" C'est bien le dossier qui contient la totalité de tes fichiers pour ton forum, donc oui tu dois envoyer avec ton client FTP ses fichiers sur ton espace d'hébergement, en écrasant ceux présent.

    Une fois la totalité des fichiers envoyés, test pour voir si tu as accès à ton admincp.

  10. #10
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    Database error

    Citation Envoyé par jolinary Voir le message
    Je vais être le plus clair possible, tu as téléchargé sur le site officiel vbulletin.com une archive en RAR, celle ci comme tu l'indique contient un dossier "UPLOAD" C'est bien le dossier qui contient la totalité de tes fichiers pour ton forum, donc oui tu dois envoyer avec ton client FTP ses fichiers sur ton espace d'hébergement, en écrasant ceux présent.
    J'ai fait ce qui a été demandé en plus de détruire le fichier x.txt.

    Citation Envoyé par jolinary Voir le message
    Une fois la totalité des fichiers envoyés, test pour voir si tu as accès à ton admincp.
    Je n'ai même plus accès à mon forum. J'obtiens le panorama Database Error. Je remarque que contrairement à d'habitude, je ne reçois pas dans ma boîte de courriel le message d'erreur correspondant lorsque ce genre d'erreur arrive (Voir la cause de ceci plus bas dans ce message).

    J'ai attendu une demi-heure environ pour voir si le problème se résorberait tout seul et cela n'a pas été le cas.

    J'ai donc décidé de vider le contenu de ma base de donnée en passant par phpMyAdmin et de restaurer une copie de ma base de donnée par Assistant de sauvegarde. Ces 2 outils sont dans mon cPanel. La sauvegarde date du 17 août 2013. Il me semble que j'avais réussi à aller au moins une fois dans mon admincp après cette sauvegarde.

    J'ai quand même encore le panorama Database Error après le restaure. Toujours pas de courriel m'avertissant et ayant pour titre :
    vBulletin Database Error!‏

    Par phpMyAdmin, je n'ai que 240 Kio pour la taille total de toute mes tables. C'est la même taille obtenu après avoir vidé mes tables.

    Pourtant le restaure semble avoir fonctionné :

    Voici le début du restaure :
    Code:
    Restauration en cours pour de la base de données 
    -- MySQL dump 10.13  Distrib 5.5.32, for Linux (x86_64)
    --
    -- Host: localhost    Database: extraits_discus
    -- ------------------------------------------------------
    -- Server version    5.5.32-cll
    
    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;
    /*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
    /*!40103 SET TIME_ZONE='+00:00' */;
    /*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
    /*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
    /*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
    /*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;
    
    --
    -- Table structure for table `access`
    --
    
    DROP TABLE IF EXISTS `access`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `access` (
      `userid` int(10) unsigned NOT NULL DEFAULT '0',
      `forumid` smallint(5) unsigned NOT NULL DEFAULT '0',
      `accessmask` smallint(5) unsigned NOT NULL DEFAULT '0',
      PRIMARY KEY (`userid`,`forumid`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `access`
    --
    
    LOCK TABLES `access` WRITE;
    /*!40000 ALTER TABLE `access` DISABLE KEYS */;
    INSERT INTO `access` (`userid`, `forumid`, `accessmask`) VALUES (4,15,1),(4,18,1),(4,14,1),(5,14,1),(5,16,1),(5,15,0),(6,14,1),(6,17,1),(5,19,1);
    /*!40000 ALTER TABLE `access` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `action`
    --
    
    DROP TABLE IF EXISTS `action`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `action` (
      `actionid` int(10) unsigned NOT NULL AUTO_INCREMENT,
      `routeid` int(10) unsigned NOT NULL,
      `packageid` int(10) unsigned NOT NULL,
      `controller` varbinary(50) NOT NULL,
      `useraction` varchar(50) COLLATE utf8_unicode_ci NOT NULL,
      `classaction` varbinary(50) NOT NULL,
      PRIMARY KEY (`actionid`),
      UNIQUE KEY `useraction` (`routeid`,`useraction`),
      UNIQUE KEY `classaction` (`packageid`,`controller`,`classaction`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `action`
    --
    
    LOCK TABLES `action` WRITE;
    /*!40000 ALTER TABLE `action` DISABLE KEYS */;
    /*!40000 ALTER TABLE `action` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `activitystream`
    --
    
    DROP TABLE IF EXISTS `activitystream`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `activitystream` (
      `activitystreamid` int(10) unsigned NOT NULL AUTO_INCREMENT,
      `userid` int(10) unsigned NOT NULL DEFAULT '0',
      `dateline` int(10) unsigned NOT NULL DEFAULT '0',
      `data` mediumtext COLLATE utf8_unicode_ci NOT NULL,
      `contentid` int(10) unsigned NOT NULL DEFAULT '0',
      `typeid` int(10) unsigned NOT NULL DEFAULT '0',
      `action` enum('create','edit','delete') COLLATE utf8_unicode_ci NOT NULL DEFAULT 'create',
      `score` decimal(13,3) NOT NULL DEFAULT '0.000',
      PRIMARY KEY (`activitystreamid`),
      KEY `score` (`score`,`dateline`),
      KEY `dateline` (`dateline`),
      KEY `typeid` (`typeid`,`dateline`),
      KEY `typeid_2` (`typeid`,`score`,`dateline`),
      KEY `contentid` (`contentid`,`typeid`),
      KEY `userid` (`userid`,`dateline`)
    ) ENGINE=MyISAM AUTO_INCREMENT=334 DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `activitystream`
    --
    
    LOCK TABLES `activitystream` WRITE;
    /*!40000 ALTER TABLE `activitystream` DISABLE KEYS */;
    /*!40000 ALTER TABLE `activitystream` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `activitystreamtype`
    --
    
    DROP TABLE IF EXISTS `activitystreamtype`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `activitystreamtype` (
      `typeid` int(10) unsigned NOT NULL AUTO_INCREMENT,
      `packageid` int(10) unsigned NOT NULL,
      `section` char(25) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `type` char(25) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `enabled` smallint(6) NOT NULL DEFAULT '1',
      PRIMARY KEY (`typeid`),
      UNIQUE KEY `section` (`section`,`type`)
    ) ENGINE=MyISAM AUTO_INCREMENT=13 DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `activitystreamtype`
    --
    
    LOCK TABLES `activitystreamtype` WRITE;
    /*!40000 ALTER TABLE `activitystreamtype` DISABLE KEYS */;
    INSERT INTO `activitystreamtype` (`typeid`, `packageid`, `section`, `type`, `enabled`) VALUES (1,1,'album','album',1),(2,1,'album','comment',1),(3,1,'album','photo',1),(4,1,'calendar','event',1),(5,1,'forum','post',1),(6,1,'forum','thread',1),(7,1,'forum','visitormessage',1),(8,1,'socialgroup','discussion',1),(9,1,'socialgroup','group',1),(10,1,'socialgroup','groupmessage',1),(11,1,'socialgroup','photo',1),(12,1,'socialgroup','photocomment',1);
    /*!40000 ALTER TABLE `activitystreamtype` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `ad`
    --
    
    DROP TABLE IF EXISTS `ad`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `ad` (
      `adid` int(10) unsigned NOT NULL AUTO_INCREMENT,
      `title` varchar(250) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `adlocation` varchar(250) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `displayorder` int(10) unsigned NOT NULL DEFAULT '0',
      `active` smallint(5) unsigned NOT NULL DEFAULT '0',
      `snippet` mediumtext COLLATE utf8_unicode_ci,
      PRIMARY KEY (`adid`),
      KEY `active` (`active`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `ad`
    --
    
    LOCK TABLES `ad` WRITE;
    /*!40000 ALTER TABLE `ad` DISABLE KEYS */;
    /*!40000 ALTER TABLE `ad` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `adcriteria`
    --
    
    DROP TABLE IF EXISTS `adcriteria`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `adcriteria` (
      `adid` int(10) unsigned NOT NULL DEFAULT '0',
      `criteriaid` varchar(250) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `condition1` varchar(250) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `condition2` varchar(250) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `condition3` varchar(250) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      PRIMARY KEY (`adid`,`criteriaid`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `adcriteria`
    --
    
    LOCK TABLES `adcriteria` WRITE;
    /*!40000 ALTER TABLE `adcriteria` DISABLE KEYS */;
    /*!40000 ALTER TABLE `adcriteria` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `adminhelp`
    --
    
    DROP TABLE IF EXISTS `adminhelp`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `adminhelp` (
      `adminhelpid` int(10) unsigned NOT NULL AUTO_INCREMENT,
      `script` varchar(50) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `action` varchar(25) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `optionname` varchar(100) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `displayorder` smallint(5) unsigned NOT NULL DEFAULT '1',
      `volatile` smallint(5) unsigned NOT NULL DEFAULT '0',
      `product` varchar(25) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      PR-- MySQL dump 10.13  Distrib 5.5.32, for Linux (x86_64)
    --
    -- Host: localhost    Database: extraits_discus
    -- ------------------------------------------------------
    -- Server version    5.5.32-cll
    
    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;
    /*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
    /*!40103 SET TIME_ZONE='+00:00' */;
    /*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
    /*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
    /*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
    /*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;
    Voici la fin du restaure :
    Code:
    --
    -- Table structure for table `visitormessage`
    --
    
    DROP TABLE IF EXISTS `visitormessage`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `visitormessage` (
      `vmid` int(10) unsigned NOT NULL AUTO_INCREMENT,
      `userid` int(10) unsigned NOT NULL DEFAULT '0',
      `postuserid` int(10) unsigned NOT NULL DEFAULT '0',
      `postusername` varchar(100) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `dateline` int(10) unsigned NOT NULL DEFAULT '0',
      `state` enum('visible','moderation','deleted') COLLATE utf8_unicode_ci NOT NULL DEFAULT 'visible',
      `title` varchar(255) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `pagetext` mediumtext COLLATE utf8_unicode_ci,
      `ipaddress` int(10) unsigned NOT NULL DEFAULT '0',
      `allowsmilie` smallint(5) unsigned NOT NULL DEFAULT '0',
      `reportthreadid` int(10) unsigned NOT NULL DEFAULT '0',
      `messageread` smallint(5) unsigned NOT NULL DEFAULT '0',
      PRIMARY KEY (`vmid`),
      KEY `postuserid` (`postuserid`,`userid`,`state`),
      KEY `userid` (`userid`,`dateline`,`state`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `visitormessage`
    --
    
    LOCK TABLES `visitormessage` WRITE;
    /*!40000 ALTER TABLE `visitormessage` DISABLE KEYS */;
    /*!40000 ALTER TABLE `visitormessage` ENABLE KEYS */;
    UNLOCK TABLES;
    
    --
    -- Table structure for table `visitormessage_hash`
    --
    
    DROP TABLE IF EXISTS `visitormessage_hash`;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE `visitormessage_hash` (
      `postuserid` int(10) unsigned NOT NULL DEFAULT '0',
      `userid` int(10) unsigned NOT NULL DEFAULT '0',
      `dupehash` varchar(32) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
      `dateline` int(10) unsigned NOT NULL DEFAULT '0',
      KEY `postuserid` (`postuserid`,`dupehash`),
      KEY `dateline` (`dateline`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
    /*!40101 SET character_set_client = @saved_cs_client */;
    
    --
    -- Dumping data for table `visitormessage_hash`
    --
    
    LOCK TABLES `visitormessage_hash` WRITE;
    /*!40000 ALTER TABLE `visitormessage_hash` DISABLE KEYS */;
    /*!40000 ALTER TABLE `visitormessage_hash` ENABLE KEYS */;
    UNLOCK TABLES;
    /*!40103 SET TIME_ZONE=@OLD_TIME_ZONE */;
    
    /*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
    /*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
    /*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
    /*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
    /*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
    /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
    /*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;
    
    -- Dump completed on 2013-08-17 14:22:35
    ****** Ce qui suit a été ajouté le 31 oct 2013 3h06 AM ****
    Lorsque j'ai copié le répertoire forums cela a remplacé le config.php par un config.php vierge. Dans le source le config.php.new avait été renommé pour config.php.

    C'est ce qui explique que je ne reçois plus le Database Error par courriel.

    Afin de corriger cela, je viens de recréer le bon config.php et je l'ai copié chez mon hébergeur.

    Suite à cette action voici le message que j'obtiens lorsque j'accède à mon forum :

    vBulletin datastore error caused by one or more of the following:
    1. You may have uploaded vBulletin files without also running the vBulletin upgrade script. If you have not run the upgrade script, do so now.
    2. The datastore cache may have been corrupted. Run Rebuild Bitfields from tools.php, which you can upload from the do_not_upload folder of the vBulletin package.




    Fatal error: vBulletin datastore cache incomplete or corrupt in [path]/includes/init.php on line
    252

    Tu ferais 1. ou 2. ou autre chose à ma place ? Autre chose serait par exemple de vider à nouveau le contenu de mes tables et de restaurer à nouveau une copie de ma banque de données. C'est peut-être à cause du mauvais config.php que la première fois ne semble pas avoir fonctionné.

    J'avais oublié de dire que j'ai détruit le répertoire «install» chez mon hébergeur après l'avoir copié de mon PC.

    Shalom !
    Dernière modification par Semeur ; 31/10/2013 à 12h56.

  11. #11
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    J'ai oublier de précisé qu'il fallait reconfigurer le fichier config.php, car pour moi ce type de procédure est instinctif.

    As tu utilisé le fichier tools.php après ta restauration, car il est nécessaire après certaines actions sur ton forum vBulletin, d'utiliser certaines options de ce fichier, comme la partie Datastore Cache, qui te permettra de vider certains caches.

    Ce fichier doit être installé dans le dossier install, avec d'autres, tu as tout ce qu'il te faut dans le dossier de ton archive vBuleltin dans le dossier "do_not_upload".

  12. #12
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    Pas de faute

    Citation Envoyé par jolinary Voir le message
    J'ai oublier de précisé qu'il fallait reconfigurer le fichier config.php, car pour moi ce type de procédure est instinctif.
    Pas de faute. De plus, avant que tu me répondes, comme je l'ai écrit, si je n'avais pas renommé config.php.new pour config.php dans mon répertoire source alors le config.php sur mon hébergeur n'aurait pas été écrasé. Quand tu m'as répondu, j'avais oublié que j'avais fait cette action.

    Citation Envoyé par jolinary Voir le message
    As tu utilisé le fichier tools.php après ta restauration, car il est nécessaire après certaines actions sur ton forum vBulletin, d'utiliser certaines options de ce fichier, comme la partie Datastore Cache, qui te permettra de vider certains caches.
    Je n'ai jamais utilisé ce fichier.

    Citation Envoyé par jolinary Voir le message
    Ce fichier doit être installé dans le dossier install,
    Sur mon poste, je crée ce répertoire. J'y ajoute le fichier en question et par FileZilla je transferts le tout sous le répertoire «/public_html/forums» de mon hébergeur ?

    Citation Envoyé par jolinary Voir le message
    avec d'autres,
    Avec d'autres quoi ? Veux-tu dire que je devrais transférer vers mon hébergeur le répertoire install du package vb et tout son contenu et ensuite j'y ajoute chez mon hébergeur le fichier tools.php ?

    Citation Envoyé par jolinary Voir le message
    tu as tout ce qu'il te faut dans le dossier de ton archive vBuleltin dans le dossier "do_not_upload".
    Je n'y prend que tools.php ?

    Comment exécuter tools.php pour mon forum chez mon hébergeur ?

    Une fois que j'aurai utilisé tools.php, je devrai détruire le répertoire «/public_html/forums/install» chez mon hébergeur ?

    Dans mon message précédent, je te posais des questions. Elles ne sont pas pertinente dans la démarche de régler mon problème ?

    Je ne suis pas certain si la copie de ma base de données que j'ai restauré était une copie faite lorsque mon forum était à la version 4.4.2.0 PL2 ou à la version présente soit 4.4.2.1. La copie de la base de données faite lorsque vb est à 4.4.2.0 PL2 est-elle restaurable sur la version vb 4.4.2.1 ?

    N.B.: J'ai une version de copie de base de données qui a été faite lorsque je me suis apperçu que j'avais été piraté donc elle provient de la version vb 4.4.2.1.

    Shalom !
    Dernière modification par Semeur ; 01/11/2013 à 16h06.

  13. #13
    Date d'inscription
    octobre 2006
    Messages
    317
    Version de vBulletin
    4.0
    Hébergeur
    Mavenhosting
    Pouvoir de réputation
    59
    Le fichier tools.php doit être placé dans le répertoire "install" celui que tu as dû supprimer en faite, il te suffit de le re créer, puis d'y mettre l'intégralité du dossier "do_not_upload", au moins tu auras la plus part des fichiers nécessaire au fonctionnement de la plus pars des options de ce fichier, mis à pars une ou deux de mémoire qui nécessite aussi des fichiers du type "vbulletin-language.xml", "vbulletin-style.xml", et d'autre, mais ils ne te serviront pas dans otn cas je pense, ils servent à restaurés la langue native, les styles, etc.

    Une fois les fichiers en place, il te suffit de rentré l'url dans ton navigateur http://www.tonsite.fr/forums//install/tools.php, le numéro "Customer Number" te sera demander.

    Après tu applique les options dans la partie "Datastore Cache", voir capture:

    01-11-2013_01.png

    Puis après regarde si tu as enfin accès à ton admincp.

    Si cela ne suffit pas, je t'invite à voir avec le support de vbulletin.com, car via un forum il me sera difficile de décelé ce qui cloche.

  14. #14
    Date d'inscription
    septembre 2002
    Localisation
    France
    Âge
    38
    Messages
    11 293
    Version de vBulletin
    5.0
    Hébergeur
    Serveur dédié OVH
    Billets dans le blog
    13
    Pouvoir de réputation
    134
    Exact, tu peux ouvrir un ticket à mon attention et je pourrais voir ça
    vBulletin Quality Assurance
    Développeur en chef de Project Tools 2.1+ pour vB 4 et 2.0 pour vB 3
    Restera très discret sur toutes les futures fonctionnalités de vBulletin ainsi que de vBulletin 5 Connect jusqu'à leur sortie publique ^^

    Tout MP d'aide -> Supprimé

  15. #15
    Date d'inscription
    février 2010
    Messages
    109
    Version de vBulletin
    4.2
    Hébergeur
    Net-solution.ca
    Billets dans le blog
    1
    Pouvoir de réputation
    46

    Ça progresse il me semble

    Citation Envoyé par jolinary Voir le message
    Après tu appliques les options dans la partie "Datastore Cache"
    C'est fait.

    Voici maintenant le message d'erreur que j'obtiens lorsque j'appel mon forum :

    Fatal error: The requested language does not exist, reset via tools.php. in [path]/includes/class_core.php on line 4103

    J'ai cliqué sur [Language] dans tools.php et j'obtiens quand même la même erreur.

    Citation Envoyé par jolinary Voir le message
    Si cela ne suffit pas, je t'invite à voir avec le support de vbulletin.com, car via un forum il me sera difficile de décelé ce qui cloche.
    Avant de contacter le support de vbulletin.com, j'attends de voir si tu as une idée; étant donné le message d'erreur qui me semble demande une action précise.

    N.B.: Entre temps, je vais détruire le répertoire «install» chez mon hébergeur.

    Shalom !

    - - - Mise à jour - - -

    Citation Envoyé par Pitchoune Voir le message
    Exact, tu peux ouvrir un ticket à mon attention et je pourrais voir ça
    Merci pour l'offre mais je vais au moins attendre d'avoir une réponse à mon message précédent.

    Dans un autre message j'avais poser la question suivante :

    Je ne suis pas certain si la copie de ma base de données que j'ai restauré était une copie faite lorsque mon forum était à la version 4.4.2.0 PL2 ou à la version présente soit 4.4.2.1. La copie de la base de données faite lorsque vb est à 4.4.2.0 PL2 est-elle restaurable sur la version vb 4.4.2.1 ?

    As-tu la réponse à cette question ?

Informations de la discussion

Utilisateur(s) sur cette discussion

Il y a actuellement 2 utilisateur(s) naviguant sur cette discussion. (0 utilisateur(s) et 2 invité(s))

Les tags pour cette discussion

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •