Affichage des résultats 1 à 7 sur 7

Discussion: Patch de sécurité pour vBulletin 3.8.7, 4.2.2 et 5.x

  1. #1
    Date d'inscription
    septembre 2002
    Localisation
    France
    Âge
    34
    Messages
    11 287
    Version de vBulletin
    5.0
    Hébergeur
    Serveur dédié OVH
    Billets dans le blog
    13
    Pouvoir de réputation
    121

    Attention Patch de sécurité pour vBulletin 3.8.7, 4.2.2 et 5.x

    Une faille de sécurité a été trouvée affectant toutes les versions de vBulletin, incluant 3.x, 4.x et 5.x. Nous avons rendu disponible des patches de sécurité pour cette vulnérabilité. Ceci inclut les patches pour vBulletin 3.8.7, vBulletin 4.2.2 et toutes les versions de vBulletin 5. Ce patch est aussi déjà inclut dans vBulletin 5.1.0 RC1. Il est impératif d'appliquer ces patches aussi vite que possible.

    Suite à ce patch, la version minimum de PHP est 5.2.0. Ceci représente une mise à jour pour vBulletin 3 et 4. Alternativement, les clients peuvent installer les fonctions JSON séparément via http://pecl.php.net/package/json, auquel cas vous n'avez pas besoin d'utiliser une version particulière de PHP. Vous devrez contacter votre hébergeur ou administrateur système pour appliquer les modifications à PHP.

    Les pièces jointes dans la discussion en lien ci-dessous sont les patchs que vous pouvez manuellement appliquer à vBulletin 3 et vBulletin 4 sans un patch dédié.

    http://www.vbulletin.com/forum/forum...-4-2-2-and-5-x
    vBulletin Quality Assurance
    Développeur en chef de Project Tools 2.1+ pour vB 4 et 2.0 pour vB 3
    Restera très discret sur toutes les futures fonctionnalités de vBulletin ainsi que de vBulletin 5 Connect jusqu'à leur sortie publique ^^

    Tout MP d'aide -> Supprimé

  2. #2
    Date d'inscription
    septembre 2002
    Localisation
    France
    Âge
    34
    Messages
    11 287
    Version de vBulletin
    5.0
    Hébergeur
    Serveur dédié OVH
    Billets dans le blog
    13
    Pouvoir de réputation
    121
    Installation du patch

    Veuillez installer le patch pour votre version de vBulletin immédiatement.

    1. Mettez à jour PHP à la version minimum indiquée ci-dessus ou installez l'extension PECL JSON si nécessaire.
    2. Téléchargez le patch depuis https://members.vbulletin.com/patches.php.
    3. Décompressez le patch de l'archive téléchargée.
    4. Placez les fichiers du patch sur votre serveur en écrasant les anciens fichiers.

    Comme tous les patchs de sécurité, nous recommandons à tous les clients affectés d'installer le patch aussi vite que possible.

    Si vous utilisez une version non patchée de vBulletin 3.x ou 4.x et que vous souhaitez appliquer les patches DIFF manuellement, veuillez consulter ces discussions :
    vBulletin 3.X
    vBulletin 4.X

    Veuillez consulter cette discussion à propos des fichiers DIFF joints si votre version n'a pas de patch direct.
    http://www.vbulletin.com/forum/forum...n-installation

    Questions fréquemment posées

    Dois-je exécuter le script de mise à jour ?
    Non, vous n'en avez pas besoin.

    Si j'applique le patch pour les versions 3.8.7 ou 4.2.2, dois-je utiliser les fichiers DIFF ?
    Non.

    Comment puis-je utiliser les fichiers DIFF pour ma version ?
    Veuillez consulter la discussion liée ci-dessus.

    Allez-vous rendre en détails les informations de cette faille ?
    Afin de permettre à nos clients de se mettre à jour et de patcher leurs installations, on ne donnera aucun détail.
    Dernière modification par Pitchoune ; 14/03/2014 à 00h55.
    vBulletin Quality Assurance
    Développeur en chef de Project Tools 2.1+ pour vB 4 et 2.0 pour vB 3
    Restera très discret sur toutes les futures fonctionnalités de vBulletin ainsi que de vBulletin 5 Connect jusqu'à leur sortie publique ^^

    Tout MP d'aide -> Supprimé

  3. #3
    Date d'inscription
    août 2004
    Localisation
    vaucluse
    Âge
    51
    Messages
    283
    Version de vBulletin
    4.2
    Hébergeur
    maven
    Pouvoir de réputation
    54
    bsr, j'ai la version 4.2.0 Patch Level 4 je dois utiliser un patch? merci

  4. #4
    Date d'inscription
    septembre 2002
    Localisation
    France
    Âge
    34
    Messages
    11 287
    Version de vBulletin
    5.0
    Hébergeur
    Serveur dédié OVH
    Billets dans le blog
    13
    Pouvoir de réputation
    121
    Citation Envoyé par mitch84 Voir le message
    bsr, j'ai la version 4.2.0 Patch Level 4 je dois utiliser un patch? merci
    Citation Envoyé par Pitchoune Voir le message
    Si vous utilisez une version non patchée de vBulletin 3.x ou 4.x et que vous souhaitez appliquer les patches DIFF manuellement, veuillez consulter ces discussions :
    vBulletin 4.X
    Tout est dit
    vBulletin Quality Assurance
    Développeur en chef de Project Tools 2.1+ pour vB 4 et 2.0 pour vB 3
    Restera très discret sur toutes les futures fonctionnalités de vBulletin ainsi que de vBulletin 5 Connect jusqu'à leur sortie publique ^^

    Tout MP d'aide -> Supprimé

  5. #5
    Date d'inscription
    août 2004
    Localisation
    vaucluse
    Âge
    51
    Messages
    283
    Version de vBulletin
    4.2
    Hébergeur
    maven
    Pouvoir de réputation
    54
    désolé je me suis mal exprimé, sur une version 4.2.0 je dois appliquer un patch sorti pour 4.2.2?

  6. #6
    Date d'inscription
    septembre 2002
    Localisation
    France
    Âge
    34
    Messages
    11 287
    Version de vBulletin
    5.0
    Hébergeur
    Serveur dédié OVH
    Billets dans le blog
    13
    Pouvoir de réputation
    121
    Le patch n'est désormais dispo que pour la dernière version. Soit tu màj à la 4.2.2, soit tu modifies les fichiers à la main.

    Tout est déjà indiqué.
    vBulletin Quality Assurance
    Développeur en chef de Project Tools 2.1+ pour vB 4 et 2.0 pour vB 3
    Restera très discret sur toutes les futures fonctionnalités de vBulletin ainsi que de vBulletin 5 Connect jusqu'à leur sortie publique ^^

    Tout MP d'aide -> Supprimé

  7. #7
    Date d'inscription
    mars 2003
    Localisation
    Sur mon coussin
    Messages
    5 536
    Version de vBulletin
    4.2
    Hébergeur
    localhost
    Pouvoir de réputation
    87
    Les patches ne sont fournis QUE pour la dernière version de chaque branche... D'où la nécessité de mettre régulièrement son forum à jour. D'ailleurs, ces mises à jour ne sont pas uniquement pour de nouvelles fonctions : elles résolvent aussi des bugs existants ainsi que les éventuelles failles de sécurité.
    Miaouuu... ne me caressez pas à rebrousse-poils, ça fait de l'électricité !
    Aucune demande d'aide par mp ne sera prise en compte !

Informations de la discussion

Utilisateur(s) sur cette discussion

Il y a actuellement 1 utilisateur(s) naviguant sur cette discussion. (0 utilisateur(s) et 1 invité(s))

Les tags pour cette discussion

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •